Hoosier Mountain Bike Association

Club News & Information (H.M.B.A.) => HMBA Forum News and Information => Topic started by: mtbikernate on January 31, 2014, 12:38:48 PM

Title: Embedding FAQ
Post by: mtbikernate on January 31, 2014, 12:38:48 PM
I have implemented a couple of functional improvements to the forum lately.


First is a fix of an annoying problem we had for awhile.


The forum used to freak out if you tried to embed too many images in a post.  I'm not sure how it behaved for others, but for me, if I tried to embed more than one image using the BBCode Flickr supplied, I would get a 403 error AND a 404 error.  Very irritating.  That one was due to some host settings.  I contacted our hosting provider about it yesterday, they flipped some switches, and now that problem appears to be gone.  Feel free to add lots of pics to your posts now.  If you have the URL to an image location, you can also insert it using the image icon in the 2nd row, 3rd from the left.  Just page the URL into the dialog box.



(http://farm4.staticflickr.com/3732/11253532346_1efbaa9d50.jpg) (http://www.flickr.com/photos/8007861@N04/11253532346/)
First Snow Ride of Winter 2013/2014 7 Dec 2013 (http://www.flickr.com/photos/8007861@N04/11253532346/) by mtbikernate (http://www.flickr.com/people/8007861@N04/), on Flickr



(http://farm8.staticflickr.com/7369/10026893805_6c1fd6c27f.jpg) (http://www.flickr.com/photos/8007861@N04/10026893805/)
2013 Brown County Breakdown (http://www.flickr.com/photos/8007861@N04/10026893805/) by mtbikernate (http://www.flickr.com/people/8007861@N04/), on Flickr


Edit 3/3/2015: The old video embed code was broken. No worky no mo. Some older video embeds will look funny with the extra code. I installed a new one that should be simpler for you all.


It works this way: Just paste the link. The plugin will do the embedding work. If you are accessing the forum with https://,  (I have a request out to the developer to get a better fix), Youtube links will throw browser security warnings. Firefox and Chrome show a gray shield up in the URL bar (Firefox is to the left of the URL, Chrome is on the right), while MSIE gives you a written warning at the bottom of the browser window that's easy to find and understand. Vimeo links don't appear to cause any problems. If youtube vids don't cause security warnings for you, be happy.


https://youtu.be/xQ_IQS3VKjA (http://youtu.be/xQ_IQS3VKjA)

http://vimeo.com/19592248 (http://vimeo.com/19592248)

http://www.pinkbike.com/video/398560/ (http://www.pinkbike.com/video/398560/)

Here is a link to the plugin website with a list of video websites that are supported. It's a LONG list. Yup, PinkBike vids also work.
http://custom.simplemachines.org/mods/index.php?mod=2681 (http://custom.simplemachines.org/mods/index.php?mod=2681)
Title: Re: Forum fixes and improvements
Post by: Unfit Nitwit on January 31, 2014, 02:08:21 PM
Thanks for digging up and posting the embedding info.
Title: Re: Forum fixes and improvements
Post by: Dave Tozer on March 05, 2014, 02:58:13 PM
Trying out the Vimeo code...


[embed=425,349]<!-- This version of the embed code is no longer supported. Learn more: https://vimeo.com/s/tnm --> <object width="500" height="281"><param name="allowfullscreen" value="true" /><param name="allowscriptaccess" value="always" /><param name="movie" value="http://vimeo.com/moogaloop.swf?clip_id=84540053&amp;force_embed=1&amp;server=vimeo.com&amp;show_title=1&amp;show_byline=1&amp;show_portrait=1&amp;color=00adef&amp;fullscreen=1&amp;autoplay=0&amp;loop=0" /><embed src="http://vimeo.com/moogaloop.swf?clip_id=84540053&amp;force_embed=1&amp;server=vimeo.com&amp;show_title=1&amp;show_byline=1&amp;show_portrait=1&amp;color=00adef&amp;fullscreen=1&amp;autoplay=0&amp;loop=0" type="application/x-shockwave-flash" allowfullscreen="true" allowscriptaccess="always" width="500" height="281"></embed></object> <p>Town Run Work Session 2014-01-18 (http://vimeo.com/84540053) from Dave Tozer (http://vimeo.com/davetozer) on Vimeo (https://vimeo.com).</p>[/embed]


Success! Great work on the site improvements!
Title: Re: Forum fixes and improvements
Post by: mtbikernate on March 23, 2014, 10:49:58 PM
Just added a right sidebar to the forum that includes an RSS feed to articles on the main page.  Watching site stats, I'm seeing that once people get to the forums, they VERY rarely ever leave to view any other content on our website.  I didn't mess around with the site layout otherwise.
Title: Re: Forum fixes and improvements
Post by: Jeff Blum on March 24, 2014, 09:58:31 AM
That looks nice on a widescreen monitor, but if I move it to the old 4:3 monitor, that + the background image take up too much of the screen real estate, leaving the thread column too narrow for my liking.  Now I usually view the forum on a widescreen monitor, so it's not really much of an issue for me, I just thought I'd make that point.  Is there a way to specify a minimum allowable width for the thread column and let it cover more of the background image?
Title: Re: Forum fixes and improvements
Post by: David Kuehnen on March 24, 2014, 10:45:29 AM
I would agree.  Although the background image is nice, I would rather have more information and less pretty.
Title: Re: Forum fixes and improvements
Post by: mtbikernate on March 24, 2014, 11:12:11 AM
Unfortunately, the forum templates aren't NEARLY as common-sense to mess around with as the main website templates are.


There is probably a way but it would require modifying the raw code of the template php files, and that's just something I only have a very basic understanding of at this point.  As for setting up the sidebar, I was fortunate to find clear instructions on what to add and where.


The Wordpress site puts most settings into a graphical interface, so they're checkboxes, fields for numbers, and a couple spots to type custom code.


I know how to add or remove the background image but from my own messing around with the browser window, that image sits behind everything and does not affect the layout width.  It looks to me like the overall layout is some kind of fluid setup based on occupying specific proportions of the browser window.  I can see if I can set a minimum width for the table I created to control the sidebars and such.


The overall layout is controlled in scattered areas throughout the template files so I don't have much to work with when setting up the sidebar for the site feed.  I can narrow it a little bit and see if I can find something a little smaller than 200 pixels that will work, but that's really all that I am able to modify at this point.
Title: Re: Forum fixes and improvements
Post by: mtbikernate on March 25, 2014, 08:08:16 PM
I narrowed the sidebar to 150 pixels.  Seems to do better without taking away from the content there.  It behaves sorta oddly when you try to squash the screen narrow enough to force horizontal scroll bars to appear.  I can't figure out how to make it behave better under those extreme circumstances.


I also added an "Important Links" section to the more important parts of the web page.  I will shortly be adding a "Volunteer With Us" link just after "Join HMBA" once Tammy gets back into town and can review the page.


I tried putting a calendar widget below the news section, and unfortunately the calendar widget just looks bad at 150 pixels.  The old width of 200 pixels is not much better.  I just don't want to cram more into the header area, either, so the link will have to suffice.


I am already seeing some forum traffic routing to the main page.  This is good.
Title: Re: Forum fixes and improvements
Post by: matt_laker on March 25, 2014, 10:29:07 PM
Awesome work, Nate!  Volunteering to help build trails is wonderful (which I know you do as well), but so is giving so much of your time to get more people aware of everything going on (to hopefully get MORE out trail building/repairing/riding).  Keep up the great work!!
Title: Re: Forum fixes and improvements
Post by: getsometrail on March 26, 2014, 06:36:42 AM
Awesome work, Nate!  Volunteering to help build trails is wonderful (which I know you do as well), but so is giving so much of your time to get more people aware of everything going on (to hopefully get MORE out trail building/repairing/riding).  Keep up the great work!!
I second this, Nate you've done an excellent job.  Our website and forum are on par with the best I've seen from other groups.  Thanks for all your effort!
Title: Re: Forum fixes and improvements
Post by: Jeff Blum on March 26, 2014, 12:09:46 PM
Awesome work, Nate!

My name is Jeff Blum, and I approve the message.  Thanks for all of your hard work, Nate.
Title: Re: Forum fixes and improvements
Post by: mtbikernate on March 26, 2014, 12:47:59 PM
Thanks for the positive words.
Title: Re: Forum fixes and improvements
Post by: Gochenour on May 01, 2014, 09:24:52 PM
There is probably a way but it would require modifying the raw code of the template php files, and that's just something I only have a very basic understanding of at this point.  As for setting up the sidebar, I was fortunate to find clear instructions on what to add and where.

I could easily duplicate this forum skin and modify the new skin's coding to allow the body width of the entire forum to stretch up to a higher percentage. That would give people options, the default skin or the skin optimized for smaller monitors. The only catch is you (the forum user) would have to go into your profile settings and select the new skin... we could set it for you as well if you asked.
Title: Re: Forum fixes and improvements
Post by: mtbikernate on June 17, 2014, 10:19:31 AM
I updated the original post in this discussion to provide some improved details about embedding from YouTube.  You have to use the old embed code from BOTH Vimeo and YouTube to display embedded vids in posts.
Title: Re: Embedding FAQ
Post by: mtbikernate on March 03, 2015, 10:00:49 PM
bump. I had to make some modifications to embedding, because the old method didn't work anymore. Now, MUCH EASIER and MORE FORMATS SUPPORTED!